re = /^PT(\d+H)?(\d+M)?(\d+S)?$/m
str = 'PT1H37S
PT1H30M15S
PT0S
PT1H0M0S
PT22H41M59S'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result