use strict;
my $str = 'PT1H37S
PT1H30M15S
PT0S
PT1H0M0S
PT22H41M59S';
my $regex = qr/^PT(\d+H)?(\d+M)?(\d+S)?$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";