import Foundation
let pattern = #"\b0+\B"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
092.01.001.220
192.16.092.000
02.1.001.01
010.064.214.210
010.064.000.150
010.000064.017.001
127.00000.0.001
10.0.00.000
010.064.105.201
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)