# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b0+\B//mg;t' <<< "092.01.001.220
192.16.092.000
02.1.001.01
010.064.214.210
010.064.000.150
010.000064.017.001
127.00000.0.001
10.0.00.000
010.064.105.201"