#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b0+\B"
Local $sString = "092.01.001.220" & @CRLF & _
"192.16.092.000" & @CRLF & _
"02.1.001.01" & @CRLF & _
"010.064.214.210 " & @CRLF & _
"010.064.000.150 " & @CRLF & _
"010.000064.017.001 " & @CRLF & _
"127.00000.0.001 " & @CRLF & _
"10.0.00.000 " & @CRLF & _
"010.064.105.201"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)