const regex = /\b0+\B/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b0+\\B', 'mg')
const str = `092.01.001.220
192.16.092.000
02.1.001.01
010.064.214.210
010.064.000.150
010.000064.017.001
127.00000.0.001
10.0.00.000
010.064.105.201`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);