use strict;
my $str = '092.01.001.220
192.16.092.000
02.1.001.01
010.064.214.210
010.064.000.150
010.000064.017.001
127.00000.0.001
10.0.00.000
010.064.105.201';
my $regex = qr/\b0+\B/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";