import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b0+\\B";
final String string = "092.01.001.220\n"
+ "192.16.092.000\n"
+ "02.1.001.01\n"
+ "010.064.214.210 \n"
+ "010.064.000.150 \n"
+ "010.000064.017.001 \n"
+ "127.00000.0.001 \n"
+ "10.0.00.000 \n"
+ "010.064.105.201";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}