import Foundation
let pattern = #"(?:http[s]*\:\/\/)*(?<dstdomain>\w*[\-]*\w*\.[a-zA-Z]*)(?:$|\:.*|\/.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
#Extract domain from url into dstdomain variable
https://www.google.fr
https://www.google.fr/search?source=hp&ei=Hr
image32.webcar.truc.fr
image32.webcar.truc-machin.fr
image32.webcar.truc-machin.fr/image/text.html
http://machin.fr
intercom.b.super.com:443
https://superdomain.com:26080/image/truc.gif
https://group.bnpparibas/agenda
group.bnpparibas:443/agenda
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)