#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:http[s]*\:\/\/)*(?<dstdomain>\w*[\-]*\w*\.[a-zA-Z]*)(?:$|\:.*|\/.*)"
Local $sString = "#Extract domain from url into dstdomain variable" & @CRLF & _
"" & @CRLF & _
"https://www.google.fr" & @CRLF & _
"https://www.google.fr/search?source=hp&ei=Hr" & @CRLF & _
"image32.webcar.truc.fr" & @CRLF & _
"image32.webcar.truc-machin.fr" & @CRLF & _
"image32.webcar.truc-machin.fr/image/text.html" & @CRLF & _
"http://machin.fr" & @CRLF & _
"intercom.b.super.com:443" & @CRLF & _
"https://superdomain.com:26080/image/truc.gif" & @CRLF & _
"https://group.bnpparibas/agenda" & @CRLF & _
"group.bnpparibas:443/agenda"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")