package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:http[s]*\:\/\/)*(?<dstdomain>\w*[\-]*\w*\.[a-zA-Z]*)(?:$|\:.*|\/.*)`)
var str = `#Extract domain from url into dstdomain variable
https://www.google.fr
https://www.google.fr/search?source=hp&ei=Hr
image32.webcar.truc.fr
image32.webcar.truc-machin.fr
image32.webcar.truc-machin.fr/image/text.html
http://machin.fr
intercom.b.super.com:443
https://superdomain.com:26080/image/truc.gif
https://group.bnpparibas/agenda
group.bnpparibas:443/agenda`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}