import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:http[s]*\\:\\/\\/)*(?<dstdomain>\\w*[\\-]*\\w*\\.[a-zA-Z]*)(?:$|\\:.*|\\/.*)";
final String string = "#Extract domain from url into dstdomain variable\n\n"
+ "https://www.google.fr\n"
+ "https://www.google.fr/search?source=hp&ei=Hr\n"
+ "image32.webcar.truc.fr\n"
+ "image32.webcar.truc-machin.fr\n"
+ "image32.webcar.truc-machin.fr/image/text.html\n"
+ "http://machin.fr\n"
+ "intercom.b.super.com:443\n"
+ "https://superdomain.com:26080/image/truc.gif\n"
+ "https://group.bnpparibas/agenda\n"
+ "group.bnpparibas:443/agenda";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}