// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:http[s]*\:\/\/)*(?<dstdomain>\w*[\-]*\w*\.[a-zA-Z]*)(?:$|\:.*|\/.*)").unwrap();
let string = "#Extract domain from url into dstdomain variable
https://www.google.fr
https://www.google.fr/search?source=hp&ei=Hr
image32.webcar.truc.fr
image32.webcar.truc-machin.fr
image32.webcar.truc-machin.fr/image/text.html
http://machin.fr
intercom.b.super.com:443
https://superdomain.com:26080/image/truc.gif
https://group.bnpparibas/agenda
group.bnpparibas:443/agenda";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}