# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:http[s]*\:\/\/)*(?<dstdomain>\w*[\-]*\w*\.[a-zA-Z]*)(?:$|\:.*|\/.*)"
test_str = ("#Extract domain from url into dstdomain variable\n\n"
"https://www.google.fr\n"
"https://www.google.fr/search?source=hp&ei=Hr\n"
"image32.webcar.truc.fr\n"
"image32.webcar.truc-machin.fr\n"
"image32.webcar.truc-machin.fr/image/text.html\n"
"http://machin.fr\n"
"intercom.b.super.com:443\n"
"https://superdomain.com:26080/image/truc.gif\n"
"https://group.bnpparibas/agenda\n"
"group.bnpparibas:443/agenda")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.