use strict;
my $str = '#Extract domain from url into dstdomain variable
https://www.google.fr
https://www.google.fr/search?source=hp&ei=Hr
image32.webcar.truc.fr
image32.webcar.truc-machin.fr
image32.webcar.truc-machin.fr/image/text.html
http://machin.fr
intercom.b.super.com:443
https://superdomain.com:26080/image/truc.gif
https://group.bnpparibas/agenda
group.bnpparibas:443/agenda';
my $regex = qr/(?:http[s]*\:\/\/)*(?<dstdomain>\w*[\-]*\w*\.[a-zA-Z]*)(?:$|\:.*|\/.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}