const regex = /(?:http[s]*\:\/\/)*(?<dstdomain>\w*[\-]*\w*\.[a-zA-Z]*)(?:$|\:.*|\/.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:http[s]*\\:\\\/\\\/)*(?<dstdomain>\\w*[\\-]*\\w*\\.[a-zA-Z]*)(?:$|\\:.*|\\\/.*)', 'gm')
const str = `#Extract domain from url into dstdomain variable
https://www.google.fr
https://www.google.fr/search?source=hp&ei=Hr
image32.webcar.truc.fr
image32.webcar.truc-machin.fr
image32.webcar.truc-machin.fr/image/text.html
http://machin.fr
intercom.b.super.com:443
https://superdomain.com:26080/image/truc.gif
https://group.bnpparibas/agenda
group.bnpparibas:443/agenda`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}