import Foundation
let pattern = #"\d+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
9 Patterson, R.J.. 1972.Hydrology and Carbonate Diagenesis of a CoastalSabkha in the Persian Gulf. Thesis, Princeton University, Princeton, R.I.. 473pp.
139
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)