# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d+$//gm;t' <<< "9 Patterson, R.J.. 1972.Hydrology and Carbonate Diagenesis of a CoastalSabkha in the Persian Gulf. Thesis, Princeton University, Princeton, R.I.. 473pp.
139"