$re = '`\d+$`m';
$str = '9 Patterson, R.J.. 1972.Hydrology and Carbonate Diagenesis of a CoastalSabkha in the Persian Gulf. Thesis, Princeton University, Princeton, R.I.. 473pp.
139';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;