# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d+$"
test_str = ("9 Patterson, R.J.. 1972.Hydrology and Carbonate Diagenesis of a CoastalSabkha in the Persian Gulf. Thesis, Princeton University, Princeton, R.I.. 473pp.\n"
"139")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.