package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+$`)
var str = `9 Patterson, R.J.. 1972.Hydrology and Carbonate Diagenesis of a CoastalSabkha in the Persian Gulf. Thesis, Princeton University, Princeton, R.I.. 473pp.
139`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}