re = /\d+$/m
str = '9 Patterson, R.J.. 1972.Hydrology and Carbonate Diagenesis of a CoastalSabkha in the Persian Gulf. Thesis, Princeton University, Princeton, R.I.. 473pp.
139'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result