import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+$";
final String string = "9 Patterson, R.J.. 1972.Hydrology and Carbonate Diagenesis of a CoastalSabkha in the Persian Gulf. Thesis, Princeton University, Princeton, R.I.. 473pp.\n"
+ "139";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}