// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+$").unwrap();
let string = "9 Patterson, R.J.. 1972.Hydrology and Carbonate Diagenesis of a CoastalSabkha in the Persian Gulf. Thesis, Princeton University, Princeton, R.I.. 473pp.
139";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}