// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\w\d\w?\.\w*$").unwrap();
let string = "t3.nano
c5n.xlarge
c5n
t3.nano.xlarge
t3.nam.t3.nano";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}