import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w\\d\\w?\\.\\w*$";
final String string = "t3.nano\n"
+ "c5n.xlarge\n"
+ "c5n\n"
+ "t3.nano.xlarge\n"
+ "t3.nam.t3.nano";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}