$re = '/^\w\d\w?\.\w*$/m';
$str = 't3.nano
c5n.xlarge
c5n
t3.nano.xlarge
t3.nam.t3.nano';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);