using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w\d\w?\.\w*$";
string input = @"t3.nano
c5n.xlarge
c5n
t3.nano.xlarge
t3.nam.t3.nano";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}