const regex = new RegExp('^\\w\\d\\w?\\.\\w*$', 'gm')
const str = `t3.nano
c5n.xlarge
c5n
t3.nano.xlarge
t3.nam.t3.nano`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}