package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w\d\w?\.\w*$`)
var str = `t3.nano
c5n.xlarge
c5n
t3.nano.xlarge
t3.nam.t3.nano`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}