#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w\d\w?\.\w*$"
Local $sString = "t3.nano" & @CRLF & _
"c5n.xlarge" & @CRLF & _
"c5n" & @CRLF & _
"t3.nano.xlarge" & @CRLF & _
"t3.nam.t3.nano"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")