re = /^\w\d\w?\.\w*$/m
str = 't3.nano
c5n.xlarge
c5n
t3.nano.xlarge
t3.nam.t3.nano'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end