import Foundation
let pattern = #"((?:[A-Z])(?=[A-Z]| and|$))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Copiez le résultat du premier outil ici.
Example:
Lauzon, L. and Lesieur, D. and Khasa, D.D. and Ruel, J.-C and Almeyda, A.M
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)