# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:[A-Z])(?=[A-Z]| and|$))/$1./gm;t' <<< "Copiez le résultat du premier outil ici.
Example:
Lauzon, L. and Lesieur, D. and Khasa, D.D. and Ruel, J.-C and Almeyda, A.M
"