const regex = /((?:[A-Z])(?=[A-Z]| and|$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:[A-Z])(?=[A-Z]| and|$))', 'gm')
const str = `Copiez le résultat du premier outil ici.
Example:
Lauzon, L. and Lesieur, D. and Khasa, D.D. and Ruel, J.-C and Almeyda, A.M
`;
const subst = `$1.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);