import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:[A-Z])(?=[A-Z]| and|$))";
final String string = "Copiez le résultat du premier outil ici.\n\n"
+ "Example:\n\n"
+ "Lauzon, L. and Lesieur, D. and Khasa, D.D. and Ruel, J.-C and Almeyda, A.M\n";
final String subst = "$1.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}