# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:[A-Z])(?=[A-Z]| and|$))"
test_str = ("Copiez le résultat du premier outil ici.\n\n"
"Example:\n\n"
"Lauzon, L. and Lesieur, D. and Khasa, D.D. and Ruel, J.-C and Almeyda, A.M\n")
subst = "$1."
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.