#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?:[A-Z])(?=[A-Z]| and|$))"
Local $sString = "Copiez le résultat du premier outil ici." & @CRLF & _
"" & @CRLF & _
"Example:" & @CRLF & _
"" & @CRLF & _
"Lauzon, L. and Lesieur, D. and Khasa, D.D. and Ruel, J.-C and Almeyda, A.M" & @CRLF & _
""
Local $sSubst = "$1."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)