$re = '/((?:[A-Z])(?=[A-Z]| and|$))/m';
$str = 'Copiez le résultat du premier outil ici.
Example:
Lauzon, L. and Lesieur, D. and Khasa, D.D. and Ruel, J.-C and Almeyda, A.M
';
$subst = "$1.";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;