using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:[A-Z])(?=[A-Z]| and|$))";
string substitution = @"$1.";
string input = @"Copiez le résultat du premier outil ici.
Example:
Lauzon, L. and Lesieur, D. and Khasa, D.D. and Ruel, J.-C and Almeyda, A.M
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}