// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((25[0-5]|(2[0-4]|1\d|[1-9]|)\d)\.?\b){4}").unwrap();
let string = "192.168.1.1
127.0.0.1
256.548.0.1
255.255.255.0
192.168.123.11
0.1
123.4
19864.684.1
123.123.123
123.123.260.123
0.3.0.1
226.0.5.1
255.255.255.255";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}