using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((25[0-5]|(2[0-4]|1\d|[1-9]|)\d)\.?\b){4}";
string input = @"192.168.1.1
127.0.0.1
256.548.0.1
255.255.255.0
192.168.123.11
0.1
123.4
19864.684.1
123.123.123
123.123.260.123
0.3.0.1
226.0.5.1
255.255.255.255";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}