import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((25[0-5]|(2[0-4]|1\\d|[1-9]|)\\d)\\.?\\b){4}";
final String string = "192.168.1.1\n"
+ "127.0.0.1\n"
+ "256.548.0.1\n"
+ "255.255.255.0\n"
+ "192.168.123.11\n"
+ "0.1\n"
+ "123.4\n"
+ "19864.684.1\n"
+ "123.123.123\n"
+ "123.123.260.123\n"
+ "0.3.0.1\n"
+ "226.0.5.1\n"
+ "255.255.255.255";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}