#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((25[0-5]|(2[0-4]|1\d|[1-9]|)\d)\.?\b){4}"
Local $sString = "192.168.1.1" & @CRLF & _
"127.0.0.1" & @CRLF & _
"256.548.0.1" & @CRLF & _
"255.255.255.0" & @CRLF & _
"192.168.123.11" & @CRLF & _
"0.1" & @CRLF & _
"123.4" & @CRLF & _
"19864.684.1" & @CRLF & _
"123.123.123" & @CRLF & _
"123.123.260.123" & @CRLF & _
"0.3.0.1" & @CRLF & _
"226.0.5.1" & @CRLF & _
"255.255.255.255"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")