use strict;
my $str = '192.168.1.1
127.0.0.1
256.548.0.1
255.255.255.0
192.168.123.11
0.1
123.4
19864.684.1
123.123.123
123.123.260.123
0.3.0.1
226.0.5.1
255.255.255.255';
my $regex = qr`((25[0-5]|(2[0-4]|1\d|[1-9]|)\d)\.?\b){4}`p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}