# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((25[0-5]|(2[0-4]|1\d|[1-9]|)\d)\.?\b){4}"
test_str = ("192.168.1.1\n"
"127.0.0.1\n"
"256.548.0.1\n"
"255.255.255.0\n"
"192.168.123.11\n"
"0.1\n"
"123.4\n"
"19864.684.1\n"
"123.123.123\n"
"123.123.260.123\n"
"0.3.0.1\n"
"226.0.5.1\n"
"255.255.255.255")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.