re = /((25[0-5]|(2[0-4]|1\d|[1-9]|)\d)\.?\b){4}/
str = '192.168.1.1
127.0.0.1
256.548.0.1
255.255.255.0
192.168.123.11
0.1
123.4
19864.684.1
123.123.123
123.123.260.123
0.3.0.1
226.0.5.1
255.255.255.255'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end