const regex = new RegExp('((25[0-5]|(2[0-4]|1\\d|[1-9]|)\\d)\\.?\\b){4}', 'g')
const str = `192.168.1.1
127.0.0.1
256.548.0.1
255.255.255.0
192.168.123.11
0.1
123.4
19864.684.1
123.123.123
123.123.260.123
0.3.0.1
226.0.5.1
255.255.255.255`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}