// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:06|\+36|0036)\d{1,2}\d{3}\d{3,4}$").unwrap();
let string = "+36301404975
06301404975
0036301404975
1234567890
0123456789
00123456789
+12345678901";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}