#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:06|\+36|0036)\d{1,2}\d{3}\d{3,4}$"
Local $sString = "+36301404975" & @CRLF & _
"06301404975" & @CRLF & _
"0036301404975" & @CRLF & _
"1234567890" & @CRLF & _
"0123456789" & @CRLF & _
"00123456789" & @CRLF & _
"+12345678901"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")